Как проверить, если ваш домашний каталог и раздел подкачки зашифрованные с помощью терминала?

Я установил Ubuntu 12.04 несколько дней назад, но как ни странно, я, похоже, пропустил часть о выборе для шифрования домашней папки. Теперь, если он зашифрован, я не знаю, что является ключом шифрования. Как я могу проверить, если это действительно зашифрованы? (а также раздел подкачки).

+267
Thomas Woodhouse 28 сент. 2011 г., 16:51:16
24 ответов

Мне очень жаль, если это был спрошен раньше, но я не могу найти соответствующий пост, что может помочь мне.

Вот проблема:

Windows 7, похоже, чтобы иметь возможность загрузиться с его собственный жесткий диск и загрузчик, но потом при попытке запустить его через загрузчик GRUB или Burg оно восходит к должности с логотипом Windows.

Он также получает распознается как Windows 8, и я не установлена, что когда-либо.

Мой макет выглядит следующим образом:

1ТБ - жесткий диск в Windows - нет загрузчика. 320гб - загрузки - как-то загрузчика Windows на нем? 250 ГБ - Жесткий диск в Ubuntu - жратва/Бург.

Теперь я могу загрузиться нормально с загрузчиком Windows, но поменяв в BIOS, чтобы перейти на Windows/Ubuntu-это боль.

Я попытался с помощью жратву customiser разобраться в загрузки Windows, но он вылетает при нажатии на "ОК".

Попробовал повторно установить загрузчик Windows, чтобы никакого эффекта.

Любые идеи?

http://paste.ubuntu.com/1457155/

Спасибо, Бен.

+873
user260943 03 февр. '09 в 4:24

Я хочу запустить скрипт на ежедневной основе, и понял, что я хотел бы использовать ту же установку, что и другие задачи cron настроен на этот сервер - поместив скрипт в каталоге/etc/cron-а.ежедневный папку.

Однако, скрипт не был запущен в одночасье - хотя другим в повседневной папку было (логи ротируются и т. д.). Сценарий принадлежит корень (как оригинальных есть), и разрешения на 755 (как оригинальных есть) - и скрипт запускается при вызове вручную.

Я нашел этот вопрос хрона.почасовой не будет работать , но не найти ответов нигде удовлетворительное - судо кронтаб -л говорит мне, что файл crontab для root (хотя, я знаю, что я могу создать один), и было бы больше смысла, чтобы использовать тот же метод, как предустановленные задания в любом случае, а не сплит хрон конфигурации.

Кто способен указать на то, что я, возможно, пропустили?

Для справки - скрипт имя Друпал

+829
Vincenzo Oliva 23 сент. 2013 г., 0:36:19

Я только что установил Ubuntu 13.04 на мой планшет Nexus 7 с помощью предварительно установленных построения изображения. Он работает, но экран очень очень медленно, и когда я вижу детали, графика говорит неизвестный. Есть ли драйвер я могу установить для этого?

+794
Peter Dolkens 18 июл. 2015 г., 0:02:15

У вас есть причина, чтобы использовать ссылку на /usr/доли/приложения/менеджер.рабочего стола?
Если вы просто копируете его на рабочий стол, вы сможете пометить как надежные :

alt text

+793
svetlana22 13 апр. 2010 г., 16:44:29

Как я могу узнать владельца и группу каталога в Ubuntu?

+776
Edmond Tamas 2 дек. 2016 г., 22:21:59

Бесплатное решение существует в репозитории, CunieFormYAGF как GNOME оболочка для него)

+759
Jwan622 28 апр. 2018 г., 19:41:53

прям - использовать сдвиг+вставка


Сочетание клавиш Ctrl+С и Сtrl+V и были сочетания клавиш, созданные для GUI приложений. Видимо как-то связано с ксерокса.


Раньше было сочетание клавиш Ctrl+с, Сtrl+х, и сочетание клавиш Ctrl+V В.. был


Сочетание клавиш Ctrl+вставка, сдвиг+удалить, а сдвиг+вставка

Они были определены в 1987 году IBM для общего доступа пользователей

Эти ярлыки часто работают в тех случаях, когда современные не надо.. т. е. в терминале.

+726
Matthew Fennell 4 мар. 2010 г., 11:04:47

Я хочу проверить безопасность своей беспроводной сети дома, но у меня много неприятностей с aircrack-НГ. Я использую 12.04 ЛТС с Linux-3.2.0-27-универсальный-Пае. Моя беспроводная карта BCM4311 (14e4:4311).

Теперь airodump работает отлично, и пакетов\ впрыска тоже (aireplay-ng не -9 как wlan0), но когда я хочу отправить поддельные авт, я получаю это сообщение

как wlan0 на канале 11, но АП использует канал 7

Я пытался установить канал с airmon и iwconfig, но это не помогло. Я не использовать любой сетевой менеджер, я читал, что это иногда вызывает проблемы.

Что я могу сделать? Нужно ли устанавливать некоторые патчи?

+713
maccam912 20 февр. 2017 г., 14:16:30

Ну, я установил новый X обновления с Ubuntu, и она отлично работает сейчас. Не уверен, что было исправлено, но это поправимо.

+644
Rares Gheorghe 12 апр. 2017 г., 14:08:39

Похоже, что мой knetworkmanager не начинать больше. Читайте: в KDE4 система лотка у меня нет значка, чтобы управлять своими сетями. Также при запуске из терминала или стартовое меню буквально "ничего" не происходит. Я не знаю, что случилось с ним.
Я попытался запустить его через АЛТ + Ф2 - тоже ничего. Может быть также стоит отметить, что в терминале никаких ошибок не возникает, команды возвращаются для следующего ввода, ни малейшего сообщения об ошибке. ó_O?

К сожалению, после прочтения этого ответа на superuser.com кажется, я не могу подключиться к WiFi через iwconfig, потому что моя сеть WPA2 зашифрованные. (В принципе я не могу установить им пароль -> недопустимый аргументошибка.)

Так кажется, я к вам knetworkmanger работает снова, так как я тоже не могу скачать другие инструменты. Я пробовал такие вещи, как

сеть-Диспетчер служб судо перезагрузка

но это не помогло.

Я немного озадачен, так что любая помощь в этом будет принята с благодарностью.

PS: Если это не стало ясно: вся драма, это просто я не могу подключиться к WiFi и интернет :о)

Редактировать:
Как предложил я попытался переустановить сетевой менеджер в KDE* и это почти так же, за исключением одной лишь разницей: он сказал что-то о чем-то.так библиотека.
К сожалению, я не смог спасти то, что флэш-диск USB монтируется только для чтения (еще одна проблема у меня -зрение).
(Это было 2 вкладыша и продолжил о том, чтобы вернуться сделать некоторые г-фу... режиме по умолчанию, поэтому я считаю, что менеджер начал без визуального ссылку (иконку в трее) ).


Однако, обратите внимание, что при соблюдении этого я повторно удалил и заново установить сетевой менеджер, чтобы увидеть, если я мог воспроизвести ошибку, но не повезло. Еще не пробовал, но перезагрузка, как я загружаю новый образ Ubuntu и правильно просто обновить всю систему после сохранения /дома.

**Если вы столкнулись с такой же ситуацией: нужно установить что-то без доступа к сети: гугл название пакета и скачать его с Ubuntu убедитесь, чтобы выбрать правильный вариант, хотя! В моем случае я получил .deb файл я просто скопировал на мою флешку и установил его в систему двойным щелчком в файловом менеджере (doplhin в моем случае). Так что не паникуйте, если вы столкнетесь с этими неприятностями! :)*

+577
Rushi Agrawal 21 сент. 2012 г., 8:25:25

Он должен работать из коробки... я думаю, вы должны сообщить об этом как об ошибке на launchpad.net.

+564
Michael Liquori 16 июл. 2019 г., 14:34:05

АПТ самом деле ничего не делает другому себя между отпуском развитие и стабильный релиз.

Однако, сам релиз перестанет изменяться, и поэтому размер списка пакетов, что apt имеет для загрузки получает намного меньше.

Давайте возьмем рвения в качестве примера.

Во время разработки, рвения-обновления и рвения к безопасности карманы оставались пустыми, но рвется карман обновляться на регулярной (каждые полчаса) основе.

После освобождения, рвутся карман не переставала меняться. Обновления теперь загружаются как новые пакеты ввода рвения-обновления и рвения к безопасности карманы.

От АПП точки зрения, рвется пакет список был загружен в полном объеме каждый раз, когда apt-получить обновление запуска во время разработки (если он был вызван два раза или более в течение полчаса, окно между выпуском обновления). Это большой список, поэтому потребовалось некоторое время.

Теперь, когда рвется отпускает, рвется пакет списка не меняется. В рвения-обновления и рвения к безопасности пакет списки меняются, но они гораздо меньше, поскольку они содержат только пакеты, которые "изменили" в рвется, так рвется выпуска.

Я вижу такое поведение в ваш apt выход в вашем вопросе. Это выглядит так, как положено: рвется карман становится только нажмите С нет загрузки; получить от рвения-обновления и рвения к безопасности соответствует фактической загрузки. Редактировать: глядя снова, похоже, что некоторые файлы были необоснованно повторно загружены, см. Мой другой ответ.

Если это слишком медленно для вас, рассмотрите возможность использования более быстрый рост, или падение достаточно большого списка ППД у вас там. Вы могли бы также бросить деб-СРЦ линий от источников.список если вам не нужен исходный код, доступный для apt-получить.

Я не верю, что вы бы увидели поведение любой другой если у вас был установлен этот релиз напрямую.

+537
Nathan Carter 29 мая 2012 г., 8:29:25

Конкретно проблема в том, что когда вы построили свой модуль, дереве исходников ядра, вероятно недостающие модули.файл symvers. Система kbuild на самом деле предупреждает вас об этом, когда вы строите свой модуль. Если Модули.symvers отсутствует, вы увидите:

Предупреждение: символ версию сброса в /usr/src/и Линукс-2.6.34-12/модули.symvers отсутствует; модулей будет иметь никаких зависимостей и modversions.

Если ваше ядро CONFIG_MODVERSIONS включена, то во время modpost этапе создания своего водителя он будет запускать скрипты/мод/modpost с -м вариантом. Если ты смел и взглянуть на Скрипты/мод/modpost.с исходным кодом, вы увидите, что в -М случае добавляется _module_layout_ символ в файл vmlinux, однако если вы не имеете модулей.symvers от вашего ядра, вы не будете получать значение CRC для данного символа и вы будете в конечном итоге с это сообщение об ошибке.

Таким образом, есть два способа обойти это.

1) выполнить полную сборку ядро для создания модулей.symvers, затем перестройте свой модуль. [http://www.mjmwired.net/kernel/Documentation/kbuild/modules.txt][1]

51 === 2. Как строить внешние модули
52 
53 Для сборки внешних модулей, необходимо иметь готовые, доступные ядра 
54, содержащего конфигурацию и заголовочные файлы, используемые при строительстве.
55 кроме того, ядро должно быть построено с поддержкой модулей. Если вы не
56 использование ядра дистрибутива, то там будет пакет для ядра вы
57 запущены вашего дистрибутива.
58 
59 в качестве альтернативы можно использовать "сделать" мишень "modules_prepare". Это
60 убедитесь, что ядро содержит необходимую информацию. Цель
61 существует исключительно как простой способ, чтобы подготовить дерево исходных кодов ядра
62 построение внешних модулей.
63 
64 Примечание: "modules_prepare" не будет строить модуль.symvers даже если
65 CONFIG_MODVERSIONS установлен; следовательно, полная сборка ядра должен быть
66 выполнены, чтобы сделать модуля работа с версиями.

2) Другой вариант-это сказать глупость modprobe для просто игнорировать все это дерьмо и просто загрузить модуль в любом случае:

команды modprobe -Ф <модуль>

Я склоняюсь к варианту 2 :)

+483
sancheZzzzzzzz 11 сент. 2018 г., 14:14:03

Попробуй сменить шифрование на WPA2, см. сетевого управления (NM-апплет). Это могло бы сработать.

+377
nkcmr 18 дек. 2013 г., 3:08:27

Обновление повлекло за собой несколько различных проблем, которые мне, наконец, удалось исправить:

Модернизация была неполной. Важные пакеты, включая новое ядро, где даже не скачали. Это оставило систему в несогласованное состояние. Можно было загрузить систему с одним из старых ядер. На другой системе я скачал пакеты ядра

Линукс-универсальный
Linux-образ-Универсальный

от http://packages.ubuntu.com/ и сохранения их на USB-накопитель.

Я установил хранилища из командной строки

судо горе -т с ext3 на /dev/sdb1/ точка_монтирования

и установить их с помощью

команды dpkg --силой-все -я точка_монтирования/Линукс-*

Я загрузил новое ядро и есть сеть, которая появилась в

команда sudo lshw -C сетевой

как отключен. Я получил это работает с

судо команды modprobe -V с r8169

которая загружает модули ядра для моей сетевой карты. Однако только по

судо программа dhclient eth0 в

интерфейс eth0 появился в команде ifconfig список и в команду sudo lshw -C сетевой. Как я могу подключиться к интернету я установил обновление с

суда apt-получить обновление Ф
судо apt-получить обновление
судо apt-получить обновление

Мне пришлось установить несколько заблокированных пакетов с судо apt-получить установку [имя_пакета]. И отдельные из них (в частности, один он) пакет с помощью dpkg -я в /var/кэш/АПТ/архивы/[пакет] как у них были конфликты (общие файлы с разных пакета).

Наконец-то я смогла загрузить полную систему, но менеджер входа в систему языка еще не работал. Перевод показывает (это известная ошибка) сообщение "низкий графический режим". Я должен был установить пакет языка-кде-зазывала и установить зазывала-сессии=перевод-кде-зазывала в форматах.конф файл.

Наконец, мне пришлось переустановить звуковые и графические пакеты, относящиеся к вам снова те.

+340
Bahtiyar Mamat 17 авг. 2011 г., 3:58:14

Убунту Выродок

+335
mattwrittle 27 окт. 2013 г., 6:02:08

Команда ИД -у распечатывает свой "числовой идентификатор пользователя" (кратко: УИД); как вы уже заметили, это так же, как изложением ваше имя пользователя в меню командной строки. Действительно, следующая команда вызовы должны иметь тот же эффект:

ИД-у судо Чаун `` /данные/дБ
судо Чаун $пользователя /данные/дБ

Причина, почему это не работает, как ожидалось, вероятно, связано с цитаты: они должны быть backquotes (код ASCII чар 0x60), а в меню сообщение об ошибке говорит о том, что вы использовали одинарные кавычки (ASCII символов типа char 0x27 раздел).

Можно найти очень подробное объяснение оболочки Unix цитирую здесь.

+245
gbesler 14 янв. 2010 г., 8:09:23

В расширения GNOME Shell являются устаревшими, это означает, что они поддерживают либо Гном Гном 3.2 или 3.3. Лучше пойти в https://extensions.gnome.org/ и проверьте, какие расширения совместимы с GNOME 3.4. Вы также можете установить их непосредственно в браузере, если требуется! Надеюсь, что помогает.

+226
Smart Shope 11 июн. 2010 г., 18:47:59

потому что я буду использовать НТВ на сервер Ubuntu 12.04.

+149
MedMarine64 15 июн. 2010 г., 19:22:47

Если беспроводной USB-это жесткая блокировка, а ну тогда значит точно аппаратная проблема. Введите настройки BIOS и включите клавиши, то попробуйте отключить или включить беспроводной. При включении клавиши действий, вам не придется удерживать нажатой функциональную клавишу, чтобы нажать клавишу F8 вместо функции клавишу F8.

+130
Eduardo Bruce 6 авг. 2018 г., 0:20:11

Твоя проблема кажется очень похожей на мою - А8 в ASUS F1A75Vpro со встроенной графикой. Не удалось полностью загрузиться примерно до 5-го сброса, иногда подряд 10-й. Всегда начинал загружаться, обычно зависает, когда 5 красных точек появились под Убунту. Но в итоге он получает через. Тогда я изменил /и т. д./По умолчанию/grub, чтобы снять всплеска/тихо, так что я мог видеть, где это нужно (вы не получаете Ubuntu и точками), и побежал обновление-жратва. Такая же проблема, но мне всегда казалось, чтобы закончить, но замерзают в последнюю минуту перед предъявлением графического интерфейса. Так я потом поставить в параметр nomodeset Linux и пока он загружается чисто каждый раз (за исключением того, что я не могу получить единство 3D и в 2D, но это неважно).

Вы могли бы попробовать то же самое, если вы иногда все-таки удается попасть.

Я ничего не знаю о ремонте, но не нравится то, что она сделала. Это, кажется, удалили жратвы-с EFI-amd64 и поставить в grub-EFI с архитектурой ia32-bin и положить много вещей в каталог /mnt. Мой каталог /mnt будет пуст, и у меня еще есть для amd64. Может быть, вы должны протирать и начать все заново.

+118
spikesa 8 апр. 2019 г., 6:00:22

Вы можете заблокировать версию, выполнив следующие простые шаги:

  1. Откройте терминал
  2. судо -Ы и нажмите Enter
  3. Введите пароль для судо
  4. Эхо Firefox и провести | команды dpkg --сэт-выбор

Это блокировка (штырь ака) пакет для Firefox'.

Чтобы снять блокировку заменить Шаг 4 с Эхо Firefox установить | команды dpkg --набор-выбор.

Если вы предпочитаете графический интерфейс, то можно открыть менеджер пакетов Synaptic, выбрать пакет и из меню выберите пакет->заблокировать версию.

+68
Bluesky 29 июл. 2010 г., 11:55:47

Что мне нравится в GNOME Shell является то, что пользователь может легко разместить разные приложения в разных рабочих областях, тем самым дав каждому из приложений на весь рабочий стол. Боль в том, что пользователь должен вручную переключить приложений между рабочими столами.

Существует расширение, что сил конкретных приложений должен быть открыт только в заранее определенных рабочих областей; например, Firefox на рабочий стол 4, банши в рабочей области 3, и т. д. Но недостатком этого является то, что если пользователь работает на рабочем столе одна и хочет запустить Firefox, он/она будет иметь 2 пустых пространств между 1 и 4. Не только это, но и программы, которые не настроены прежнему открытого в текущей рабочей области.

Есть ли расширение или скрипт, который заставляет новых приложений в последнем открытом пространстве (пустой), независимо от того, сколько рабочих областей открыты?

+43
timbud 29 авг. 2013 г., 21:31:06

Я только недавно купила HP DV6T-7000 Quad в редакции. Он имеет процессор Intel с HD 4000 и NVIDIA серии GeForce GТ 650M с 2 ГБ с Оптимус. Я читал, что я мог бы использовать, чтобы сделать Шмель Оптимус работы, так что я установил его. Я также установил Шмель-и NVIDIA-Current из-за Убунту-х-сват/х-обновления ППА. Я перезагрузился, но когда я попытался запустить что-нибудь с и optirun, компьютер подождите десять секунд или около того, затем сделать жесткий отключения. У меня нет сообщений в журнале от Шмеля, xorg или и optirun, либо. Я очистил и переустановил Шмель, шмель-с NVIDIA, и NVIDIA-текущая. Я также отключить управление питанием для NVIDIA в шмеля.файл conf не помогло. Я из идей по этому поводу, и мне нужны оба варианта графики. Любой идеи будет высоко ценится.

Обновление: Сегодня (6/14/12), я обновил ядра (до версии 3.2.0-25) и переустановить Шмель-и NVIDIA-текущая (от ППА:upubuntu-ком/NVIDIA с драйвер 295.59) так что новый драйвер будет основываться на новом ядре. Я заметил несколько вещей:

  1. И optirun работал (с различными ошибками).
  2. Мне пришлось команды modprobe NVIDIA и-текущая и команды modprobe -р от Nvidia-Current до меня и optirun, чтобы остановить, рассказывал мне, что карта упала с автобуса.
  3. Как только я сделал это, я был в состоянии бежать без приложений OpenGL с и optirun; однако, запуск приложений OpenGL даст мне ошибку на Xlib: Extension "в комплектации GLX" отсутствует на дисплее ":8".
  4. Поиски быстро принесли следующие страницы: https://github.com/Bumblebee-Project/Bumblebee/wiki/Troubleshooting в котором перечислены мои проблемы. Следуя инструкциям в разделе в результате я имея тот же вопрос (остановов), что я написал о первоначально.

Я тоже нашел эту статью, где кто-то сказал в комментариях, что он испытал тот же вопрос, если его не запустить программу на CUDA перед запуском и optirun. (комментарий номер 9). Я постараюсь это и увидеть, если он работает, если это возможно, я могу добавить программу быстрые CUDA для моего сценария?

Спасибо всем, кто уже ответил, Я очень ценю вашу помощь.

Обновление #2:

Сегодня (6/23/12), я переключился на вариант xorg-обрезки ППА , чтобы увидеть, если новые драйверы/xorg, выполнив команду файл/etc будет исправить мою проблему. Сейчас я получаю те же ошибки, перечисленные выше в пунктах 1, 2 и 3. Я не пробовал Шаг 4 еще и потому, что я не хочу разрушить то, как я сделал в прошлый раз (по крайней мере, теперь не гл приложений).

Кроме того, CUDA-это становится мне некуда из-за ошибок, так что сейчас, это вопрос.

+17
mpearce 4 мая 2018 г., 9:53:31

Показать вопросы с тегом